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About ACPN: 
 

Asian City Planners Network is a platform for all the Urban Planners, Spatial 

Planners, Transport Planners, Housing, Regional and Environmental Planners 

etc. Under one roof for all the Asian Cities. It is a collection of volunteers 

maintaining the entire network. Asian Cities today are the most diverse and 

rapidly changing in the world. With the increase in demand for rapid changes in 

society. we aim to create a pool of resources for all the urban planning 

professionals and students. With the available information about the city and 

with the available pool of knowledge about the best practices for every aspect. 

At ACPN we dream to plan for cities which are Inclusive, Sustainable, Safe and 

Resilient wishing to achieve the SDG Goal 11, Pan Asia. 

 

 

"Cities today are the most complexly intertwined engineered 

systems, designed to manage infrastructure around the adequate 

resources and flow of information" 

 

Asian Cities today are more and more dependent on the field of  city planning. Yet, 

they are facing the challenge of under managed resources. At ACPN we try to 

achieve the simplest idea for the most effective planning of  public space in which 

we live today, trying to follow the dream of 'Building Greater Asia' with inclusive, 

safer, resilient and sustainable future cities.  

 

 
We are a network of students who came together and volunteer with self-funds in order 

to create awareness about our profession called 'Planners' in South Asia. 
I call upon all the students to join our drive! #ACPN #KnowPlanning  

 

#StayHomeStaySafe 

 

 
Founder, ACPN 

dc.acpn@gmail.com 
 

  March 2020 

mailto:dc.acpn@gmail.com
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ABOUT HYDROLOGY TOOL: 

The Hydrology tools are used to model the flow of water across a surface. 

Information about the shape of the earth's surface is useful for many fields, such as 

regional planning, environmental planning, agriculture, and forestry. These fields 

require an understanding of how water flows across an area and how changes in that 

area may affect that flow. 

When modelling the flow of water, you may want to know where the water came from 

and where it is going. The following topics explain how to use the hydrologic analysis 

functions to help model the movement of water across a surface, the concepts and key 

terms regarding drainage systems and surface processes, how the tools can be used 

to extract hydrologic information from a digital elevation model (DEM), and sample 

hydrologic analysis applications. 

 Understanding drainage systems 

 Exploring digital elevation models (DEM) 

 Deriving runoff characteristics 

 Creating a depressionless DEM 

 Creating watersheds 

 Hydrological analysis sample applications 

The Hydrology tools can be applied individually or used in sequence to create a 

stream network or delineate watersheds. 

Tool Description 

Basin Creates a raster delineating all drainage basins. 

Fill Fills sinks in a surface raster to remove small imperfections in the data. 

Flow 

Accumulation 

Creates a raster of accumulated flow into each cell. A weight factor can 

optionally be applied. 

Flow Direction 

Creates a raster of flow direction from each cell to its steepest 

downslope neighbor. 

https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/understanding-drainage-systems.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/exploring-digital-elevation-models.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/deriving-runoff-characteristics.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/creating-a-depressionless-dem.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/how-watershed-works.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/hydrologic-analysis-sample-applications.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/basin.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/fill.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/flow-accumulation.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/flow-accumulation.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/flow-direction.htm
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Tool Description 

Flow Length 

Calculates the upstream or downstream distance, or weighted distance, 

along the flow path for each cell. 

Sink Creates a raster identifying all sinks or areas of internal drainage. 

Snap Pour Point 

Snaps pour points to the cell of highest flow accumulation within a 

specified distance. 

Stream Link 

Assigns unique values to sections of a raster linear network between 

intersections. 

Stream Order 

Assigns a numeric order to segments of a raster representing branches 

of a linear network. 

Stream to 

Feature 

Converts a raster representing a linear network to features representing 

the linear network. 

Watershed Determines the contributing area above a set of cells in a raster. 

ArcMap Hydrology Process Flow Chart 

 

Note this document is focused on ArcMap only. For, QGIS I would recommend to 

view this video here. 

https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/flow-length.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/sink.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/snap-pour-point.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/stream-link.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/stream-order.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/stream-to-feature.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/stream-to-feature.htm
https://desktop.arcgis.com/en/arcmap/10.5/tools/spatial-analyst-toolbox/watershed.htm
https://www.youtube.com/watch?v=Ro-RRzMMw-c
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Step 1: Open GIS (ArcMap) 

 
Step 2: Add/Create DEM file into the Data frame. 
If you need to create a DEM you can, but if you already have the file you just need 

to add it for the further processing. 

I am  just adding the file that I have with me downloaded from Bhuvan (Need to 

know how to download the file, Click Here). For this exercise I have attached the 

.gdb file to perform the further steps with ease. 

Step 2.1 : Add Data 

 
Step 2.2: Select the geodatabase (.gdb) file I have provided you. 

 
Step 2.3: Select the DEM tiff (here with the name cdng file) 

https://37f72a51-cbaa-4298-a2d2-3c09a9b7a0e5.filesusr.com/ugd/80495f_b7e491e986d54880a6de092d7d0fda1c.pdf
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Step 2.4: Before proceeding further, first set the spatial reference. To do so click on 

Layer (Data Frame) then properties. Click on coordinate system from the  
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Search for UTM. 

 

You can refer the map below to know what UTM zone your study area will be. For 

now, the DEM file corresponds to the Sikkim region. 

 

Select UTM>WGS 1984>Northern Hemisphere>WGS 1984 UTM Zone 45N>Ok! 
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Step 2.5: Project the original DEM file to UTM. 

Right click on the cdgn (DEM file)>Data>Export Data>Click on Dataframe on 

Spatial reference on top right (as shown in fig. below)>Change 

Name>Sikkim_DEM>Ok! (Note:Mind the Location before clicking OK, select the 

preferred output, here save everything in the given .gdb file) 
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Step 2.6: Mosaic or Raster Clip. Many times the study area you need to perform 

Hydrology analysis will either be larger need two titles of DEM or smaller. In case of 

larger area, you need to perform Mosaic (if you donot know how to, Click Here). In 

case the study is area is smaller, then raster clip need to be performed.  

Toolbox>Data Management Tools>Raster>Raster Processing>Clip 

 Input: Sikkim_DEM; 

Output:Sikkim_DEMC; Note: Check both boxes in the dialogbox highlighted in red 

in above picture.  Or You can skip this step! 

Step 3: Open Hydrology Tools. 
Click on Arc toolbox in the top ribbon. 

 

The Toolbox popup appears, Select Spatial Analyst>Hydrology. 

 

https://www.youtube.com/watch?v=JWeYsAFPfxU
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Step 4: Fill 
The first step is Fill; a sink is a cell with an undefined drainage direction; no cells 

surrounding it are lower. The Fill tool uses the equivalents of several tools, such as 

Focal Flow, Flow Direction, Sink, Water shed, and Zonal Fill, to locate and fill sinks. 

(As shown in the figure below). 

  

So simply Fill, sinks in a surface raster to remove small imperfections in the data. 

So, to perform fill; Toolbox>Spatial Analyst>Hydrology>Fill. 

Input: Sikkim_DEMC.tiff ; Output: Sikkim_Fill.tiff 

OK! 

 

 

Notice the low value changed, due to  

the Fill tool. 

               

HELP!! 

Input surface raster  

The input raster representing a continuous surface. 

Output surface raster  

The output surface raster after the sinks have been filled.If the 

surface raster is integer, the output filled raster will be integer 

type. If the input is floating point, the output raster will be floating 

point. 

Z limit (optional)  

Maximum elevation difference between a sink and its pour point 

to be filled. 

If the difference in z-values between a sink and its pour point is 

greater than the z_limit, that sink will not be filled. 

The value for z-limit must be greater than zero. 

Unless a value is specified for this parameter, all sinks will be 

filled, regardless of depth. 



Hydrology Tool   Guidance Document 

Asian City Planners Network  9 

Step 5: Flow Direction 
Click on Hydrology>Flow Direction. 

Creates a raster of flow direction from each cell to its steepest downslope neighbor. 

 

Input: Sikkim_Fill; Outpu: Sikkim_FlwDir 

  

  

Note: This is very important if  

you are doing RUNOFF!! 

HELP!! 

Input surface raster  

The input raster representing a continuous surface. 

Output flow direction raster  

The output raster that shows the flow direction from each cell to 

its steepest downslope neighbor. This output is of integer type. 

The output of the Flow Direction tool is an integer raster whose 

values range from 1 to 255. The values for each direction from 

the centre are shown as above.  

OUTPUT 



Hydrology Tool   Guidance Document 

Asian City Planners Network  10 

Step 6: Flow Accumulation 

Creates a raster of accumulated flow into each cell. A weight factor can optionally be applied. 

 

Input: Sikkim_FlwDir ; Output: Sikkim_FlwAcc 

 OK! 

 

 

 

 

 

HELP!! 

Input flow direction raster  

The input raster that shows the direction of flow out of each cell. 

Output accumulation raster  

The output raster that shows the accumulated flow to each cell. 

Input weight raster (optional)  

An optional input raster for applying a weight to each cell.If no 

weight raster is specified, a default weight of 1 will be applied to 

each cell. For each cell in the output raster, the result will be the 

number of cells that flow into it. 

OUTPUT 
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Step 7: Conditional (Con) 
Reminder: Before going anyfurther save the .mxd!! 

Spatial Analyst>Conditional>Con 

Performs a conditional if/else evaluation on each of the input cells of an input 

raster. 

 

Input Conditional raster: Sikkim_FlwAcc ; Input true &False raster: Sikkim_FlwDir; 

Output: Sikkim_Con 

<Output 
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Step 8: Stream Order  
Assigns a numeric order to segments of a raster representing branches of a linear network. 

 

Input Stream Raster: Sikkim_Con; Input Flow Direction: Sikkim_FlwDir;             

Output raster: Sikkim_StrmO; Method of Stream Ordering (default). 

 
Famous Stream Order Methods 

 <Output 

Higher the no. bigger the stream. 
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Step 8: Stream to Feature  
It converts the raster to vector layer from the Stream ordered layer. 

 

Input Stream Raster: Sikkim_StrmO; Input flow direction: Sikkim_FlwDir;         

Output: Sikkim_Streams 

 

^ Output; If you have clipped the file you will see this ^  

What is it?? Right, that is a good question. These are streams till lower order, we do not 

need them always at this scale. So, the next step is to view them. 

 

Note: Sometimes the streams to feature takes time, so it always need patience!   
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Step 9: Definition Query 
Right click on the stream layer (remember it is a vector now). 

Definition Query is a SQL based calculation and selection tool, which performs and 

shows only as per the expression you enter. Here, we need to select the streams 

above certain order say we wanted to higher stream orders. Hence, we perform as 

shown below. 

Properties>Definition Query> Query Builder 

  

Now select grid code. Then >= 6 (it means we want to see only those streams 

above order of 6)> OK 

 

To make it more visual, click on properties>Symbology>Categories>Unique Value 

>Value field > . 
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You can change color scheme of the orders like shown in below.>Apply

 

Step 10: Basin 
Creates a raster delineating all drainage basins. Input>FlowDiection. 

 

^Output 
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Step 11: Snap Pour Points 

Catalog>go the .gdb location> Right Click>New>Feature Class

>dialog box> 

>Name>Alias>Type of Feature>Point>Click Next>

>Select the UTM 45N (similar to Step 2.4) >Click Next>Click Next>add one more 

filed with name PP(Feature type Double)>Finish 

Step 11.2: Keep the Stream layer on>start editing (for pour points)>Click on create 

features> >Select pour points>create points 

where you think outfall are if know, otherwise create point on the nearest stream 

order link such as > 
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Create as many points you need watershed for.(as shown below) 

 

Step 11.3: Toolbox>Spatial Analyst>Hydrology>Snap Pour Points>Input raster or 

pour points feature: Select the created pour points>Input flow accumulation: Select 

Sikkim_FlwAcc>Give output raster name:________>Select Snap Distance to 0 (>OK! 

< Output 
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Step 12: Watershed 
Hydrology>Watershed>Input flow direction: Sikkim_FlwDir>Input rater or feature 

pour point data: Select the snaped pour points data>Set output name to 

Watershed> OK!! 

 

 

^Final Output 

Note: Watershed delineation depends upon where are the pour points taken. 
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